読者です 読者をやめる 読者になる 読者になる

gitを使ってみる

Debianを使っているので、apt-get install git-coreだと最新版がインストールできないとのことです。

sudo apt-get build-dep git-core
sudo apt-get install openssl
sudo apt-get install libssl-dev

それから、下記URLから最新のターボールをゲットします。
http://www.kernel.org/pub/software/scm/git/

解凍して、make all して...

SUBDIR git-gui
GITGUI_VERSION = 0.12.0.23.ga91be
    * new locations or Tcl/Tk interpreter
    GEN git-gui
    INDEX lib/
    * tclsh failed; using unoptimized loading
    MSGFMT    po/de.msg make[1]: *** [po/de.msg] エラー 127
make: *** [all] エラー 2

エラーが発生。よく分かりません。

ぐぐる。このサイトを発見>>http://d.hatena.ne.jp/umedoblock/20090622/1245679860 感謝!!

これで、Debianで最新のgitをインストールできました。